Help! Have to Do Demo For Client: Desktop Not Launching Properly

I have an installation for about year now without significant issue.
Running desktop 1.3.4 (also reinstalled it.)

Issue launch Desktop and the normal window showing finding frameworks and the like does not show up. Also there is no window to manage the databases.
Activity monitor shows it running. There are just no windows.
I am using Mac 10.15.6 and this worked an hour ago. I have tried restarting.

I am supposed to do a demo with a client in 30 min but that seems like a fail now.

What should I do to get things back working?


I think I solved it.

I went to finder and did a "show package contents" from there I launched and launched the "Neo4j Desktop" from the MacOS folder. It opened a terminal and started and then showed an error about not finding a database in the com.Neo4j.Relate>Data>dbmss> folder. Looking at that folder there was an alias to a file and other alias to data folders. The one to the file was what was identified as not being found. I removed that alias from the directory and relaunched Neo4j Desktop and it launched correctly (with 2 min to spare to my demo).

The alias was probably the one from the deleted a database from the desktop browser in the last working session. Somehow the deletion process didn't complete and caused the desktop to error out.