Halin v0.11 is now available! (The Trivium release)

Here's a run-down of what's new. With many thanks to everyone who reported an issue or provided feedback, the evolution of this thing has benefitted majorly from your time and care.

Run it now:



Install directly into Neo4j Desktop here: https://install.graphapp.io/

1 Like

Getting white screen with the new version on all my Windows machines:

Hi David, I'm experiencing the same behaviour reported above on OS X using Halin 0.11.1 and Neo4J Desktop

When I try to launch the Halin app, the new window displays the loading animation for half a second or so, before going completely white and then nothing further loads.

Happy to test out any suggestions you might have, thanks.

Hi guys -- can you please do this and screenshot the results:

Launch desktop, start Halin, then in the top app menu choose Developer -> Developer Tools. You'll get an extra developer toolbar at the bottom of halin. Then choose the "Console" tab and send me a screenshot.

Looking for something that looks like this:

Here it is:

So basically there is no error here. Hmmm.. Would you please try removing the app altogether and installing it fresh, and then repeating the same?

Also - do you have any network blocking in place? I'm wondering if the app is failing to load something it needs remotely.

I get the same error-free console log on OS X.

I tried removing and reinstalling Halin, but the same behaviour persists.

If it's relevant, I've tried using it against both a local database and remote causal cluster, with the same result.

Thanks for your help David, if I can do any further testing please let me know.

In this scenario I'd be looking at the developer console to see if there are any network errors fetching resources. I'd also see if you can check the DOM to see if the document is loading in the first place. Also please indicate which version of Neo4j Desktop you're using, maybe we can have someone from the desktop team take a look.

Attached is a screenshot of the network panel of the developer tools, there look to be 3 requests to the GraphAppContainer, which all complete without error.

I've also attached a screenshot of the DOM.

This is happening in OS X using Neo4J Desktop v

It also happens on clean windows 10 vm with only neo4j desktop v1.2.0 installed.

Something else to try -- apparently desktop makes some changes to the standard developer tools that make issues a bit tough to see. In Desktop click on the gear icon, scroll all the way to the very bottom, and toggle "Enable Development Mode". You should then launch halin, and you'll see this:

Choose app developer tools, and then you'll get another console like what we were trying above. Please report back with the console and any network load errors you see there.

@maddoc1 and @terryfranklin82 -- thanks for your persistence here. A coworker helped me find the error. It was a packaging error in the way halin was put together. I've issued a v0.11.2 release to address it. Please try once more uninstalling and reinstalling halin, and it should work now.

Let me know how it goes!

1 Like

@david_allen honestly I think it's your persistence that should be applauded, firstly for both developing tools like this (and others - your articles on k8s causal cluster deployments & backups have been invaluable for me) but also in helping to debug them. It's greatly appreciated.

I've installed 0.11.2 and can now use it for a local graph, which is great. Against a causal cluster I'm receiving the familiar 'Websocket connection failure' error but I'm guessing that is down to the endpoint resolving to an AWS load balancer, or similar cluster setup issue. I'll look further into it and let you know if I can't solve the issue, thanks again.


Thanks for submitting!

I've added a tag that allows your blog to be displayed on the community home page!