The new app Graphlytic for visualization is not working. Once following all the steps for its installation and launch it takes me to .Neo4jDesktop folder and I am not sure what to do post that.

Can you share more details? I.e. the steps you took for the install?

There will be a new version soon that makes it easier to install.

Once installing the app, I decided to run the app. As mentioned on online resources, it asked me to add the plug in and restart the app and database. I did that. However, when I restart the the Graphlyltic app it directs me to .Neo4JDesktop file and nothing else happens. I am not sure how to proceed after that.

Which operating system and which version of Neo4j Desktop do you use?

I am using Windows with the following versions:

Neo4J Desktop : 1.2.1
Neo4J Browser: 3.5.6

We've released Graphlytic Desktop 2.0.0 which uses Neo4j Desktop's plugin dependency mechanism, this should solve your problem. Please upgrade Graphlytic in your Neo4j Desktop (if it's not upgraded automatically please remove Graphlytic from Neo4j Desktop and install it again).

Blogpost on how to install Graphlytic in Neo4j Desktop:

Note: please be sure that no application is running on localhost:8080 and localhost:8443 ports because these are used by Graphlytic server which is started when you launch Graphlytic in Neo4j Desktop.

1 Like


It is still not working. When I start the graph app and the Graphlytic I get this option. I do not know what to do next and the projects folder has nothing in it.

Please send the logs from Graphlytic Desktop to

Logs are located in <NEO4J_DATA_DIR>/graphApps/_global/graphlytic-desktop/dist/log/

<NEO4J_DATA_DIR> location can be found in Neo4j Desktop:
1 - click on the icon marked with "1" in the picture below
2 - use the path from the field marked with "2" in the picture below

Other suggestions:

  • Please review if the Neo4j Graphlytic Plugin is installed correctly - look at number "3" in the picture if it looks the same in your Neo4j Desktop
  • Please review if your Graphlytic Desktop installation was upgraded correctly - look at the version number of your Graphlytic Desktop app - number "4" in the picture
1 Like

I have followed the path and it is empty. I am not sure what might be wrong. I have updated the graph app as well.

Graphlytic Desktop 2.2.0 was released yesterday. There was a problem with launching local Graphlytic Server when the app was installed in folder containing spaces. I see from your screenshots that the app is indeed installed in folder with a space in the name.

Please upgrade Graphlytic Desktop in your Neo4j Desktop (the upgrade should start automagically on Win) to version 2.2.0 and try to start it.

Dear Michael,

I think the Graphyltic app has started working. But I am not sure about one thing. I am trying to connect it to an existing database that I created in Neo4J. But when I am opening the Graphyltic app, it is showing me a blank sheet.

Do I need to import my data again? Or is there something that I am doing wrong?

When you create a new visualization it's a blank workspace where you can put nodes and relationships from connected Neo4j. You can use the search field in the center of the header to look for nodes (fulltext search) and by clicking on them place it to the worspace. Them by doubleclicking on the you can "expand" the nodes, e.g.load relationships of clicked node.

Before using the fulltext search please setup the index and reindex the db. Please see the steps in this picture:
1.Open the "Fulltext search configuration"
2.Choose properties that will be indexed
3.Click on "Start indexing"

Dear Michael,

I shall try that and let you know....

Thanks once again...

Dear Michael,
I think I am following it. I am able to see nodes and their properties. Is it possible to see visualization of certain queries as well in the app. Let say, the database schema or visualization of graph algorithms?

You can write your own cypher queries and visualize the output (if there are some nodes or relationships returned) with the Search & Manage data (also awailable as the Advanced Search from visualization's search field). More info is here :

I shall give it a try...

Getting an issue with this too, I'm on 2.2.1, I have Neo4j installed on my D: drive and Graphlytic seems to expect everything to be in C:\program files
I assume I could modify the .bat file to point to the right location, some pointers to what to change would be helpful..

I've just tested the installation on D drive in folders with spaces and I can't reproduce the issue. Can you please send your logs to for further inspection?

Be sure to use a local graph with Graphlytic Desktop. Connection to remote graphs is supported only in Graphlytic Server (on-premise installation or in our cloud) - a Free Trial of Graphlytic Server can be downloaded from webpage.

My setup:

  • Neo4 Desktop 1.2.3
  • Graphlytic Desktop 2.2.1
  • Windows 10
  • Local graph

Thanks for checking - will send the logs when I can.
I am only using a local graph


I am having issues with the app. I am using neo4j desktop 1.2.4 on a windows 10 machine and everything is installed to the defaults.
I've tried installing the app today from both the Graph App Gallery and the way in the guide here: (

The app installs, but whenever I try to open it it tells me that the plug in is not installed. When I check available plugins i see the following:

Can you please help me how to resolve this issue?