Getting Started guide in GraphAcademy online training not working

I'm trying to use the "Get Started with Graph Databases using Neo4j" tutorial under "Online Training", but the "sign in" button under "Launch the training" doesn't seem to do anything.

Here's the link.

If I check the browser console, I see this error -

Uncaught TypeError: Cannot read property 'get' of undefined
at gcSendEvent ((index):412)
at record_event ((index):438)
at loginButtonAction ((index):407)
at HTMLButtonElement. ((index):427)
at HTMLButtonElement.dispatch (jquery-3.3.1.min.js?ver=3.3.1:2)
at HTMLButtonElement.y.handle (jquery-3.3.1.min.js?ver=3.3.1:2)

But when I open the link in an incognito window, the button seems to work fine.

What do I do to fix it?

It's working for me with Mac OS and Chrome, can you tell us your OS, browser type, and browser version?

Hi, Thank You for responding!

I am on Windows 10, using Google Chrome v70.

If it helps, I made a screen recording that shows the error.

Any ideas as to how I might get around this? I'm still getting this error.

I'll see who I can contact on our end of things to investigate.

Thanks @andrew.bowman for the referral.

Thanks for your persistence @manish.giri.me . The problem is that the code expects Google Analytics to be loaded and does not handle cases where it is not. It's possible that you have a privacy blocker enabled or did not click the 'Accept' button on neo4j.com, leading to Google Analytics not being loaded.

We've actually moved to a new Online Course in the months since your initial report. This new course is located here: https://neo4j.com/graphacademy/online-training/introduction-to-neo4j/.

This course still has the same problem right now-- but I'll work on placing some error handling around the underlying issue to prevent it from impacting your course experience. I'll followup on this thread shortly when that is complete.

Cheers,
-Ryan

Okay, this new course should now handle that error condition much better (and allow you to proceed even if it can't contact Google Analytics).

Let me know if that works for you!

Cheers,
-Ryan

Hi Ryan,

Thank You for the quick updates.

Although I do understand the underlying problem, I was actually using the new course itself earlier today, when I encountered that error, which is when I decided to come back to this post to check if there were any updates.

This is the URL that I had bookmarked in Chrome - https://neo4j.com/graphacademy/online-training/introduction-to-neo4j/part-4/

I had completed up to Part 3 a few days back, during which time I had used my Github account to login. I think that data may have been erased in the meantime, which is why I saw the "sign in" button today, when I resumed Part 4, at which time I encountered the same error as earlier.

I'm currently using Safari to continue with the rest of the course, and if I come across this problem again, I'll post here.

Thank You,
Manish

Hi Manish,

I’m guessing the JavaScript was cached for you - hence why it did not work after the fix.

Glad it’s working for you in Safari tho.

Cheers
Ryan

It's working for me on Windows 10 and Google Chrome Version 72.0.3626.109 (Official Build) (64-bit)

1 Like

It seems to be broken again.

I am on Firefox and Ubuntu 18.04. I was previously able to log in after disabling ALL privacy blockers (the necessity of which is a huge black mark in our eyes, btw), but now I'm not able to log in at all. Whenever I hit the sign-in button, it takes me to "redirecting..." and then I'm right back where I started, needing to sign in.

Update:

I have the same problem on MacOS and Firefox. With Safari, I'm able to log in. However, since my work device is Ubuntu, I don't have the option of installing Safari on it.

It's not working for me either. I've been enrolled for a couple of months and accessing it a couple of hours a week. Haven't accessed in about two weeks, and now can't access the course.

I'm trapped in a redirecting loop back to https://neo4j.com/graphacademy/online-training/introduction-to-neo4j/.

I'm using Google Chrome on Windows 10.

Found this forum since I'm having the same issue today. I'm on windows 10 and tried chrome, edge, and IE and can't access any training since the Sign In button doesn't do anything. I've tried accepting the cookies to no avail

Hello and welcome to the Community!

From what you are describing, your Web browsers have a JS extension like and ad blocker that is preventing the sign-in button from working. It is also possible that you may be using a VPN that prevents access. If so, can you log out of the VPN while you are accessing the site? And of course a Firewall may also be blocking.

Hopefully one of these things will solve your issue. Please let us know if you cannot sign in.

Elaine