Getting "Neo4jError: Could not perform discovery. No routing servers available" while accessing from NodeJS


I created a database in neo4j aura. I was given a bolt+routing URL.

This works when accessed via the Neo4j browser. I am trying to access it via firebase functions (NodeJS). I got the below error.
Error: Unknown scheme: bolt+routing

Then I found the below in the neo4j documents.
"bolt+routing scheme is now renamed to neo4j. neo4j scheme is designed to work work with all possible 4.0 server deployments, but bolt scheme is still available for explicit single instance connections."

I changed bolt+router into neo4j.

Now, I get the below error.

err { Neo4jError: Could not perform discovery. No routing servers available. Known routing table: RoutingTable[database=default database, expirationTime=0, currentTime=1576732474763, routers=, readers=, writers=]

Initially, I got the same error while I accessed the community edition hosted in a GCP instance. Now it is happening with Aura.

Thank you.

1 Like

I'm getting the same error. I'll be trying to solve it for the next few hours and will update if I find a solution. (If I don't update I didn't find any.)

I am also getting the same error. Tried with carious combination but nothing worked.

I reverted back to neo4j-driver v1.7.6 and everything worked as expected.
I think this issue is related to the latest driver itself.

I have resolved my issue by switching from neo4j:// protocol to bolt:// according to these instructions. It may not work for you, but for me it was a problem with following driver documentation for one version (4.x.x) and having the neo4j server be another version (3.x.x).