Getting Error : " ServiceUnavailable: WebSocket connection failure. "

I am using neo4j 3.4.1 installed on Linux 7.5 server.
It was working fine all these days , but after I upgraded my Microsoft Office , it started giving following error when I try to access neo4j in chrome browser

Error message:

ServiceUnavailable: WebSocket connection failure. Due to security constraints in your web browser, the reason for the failure is not available to this Neo4j Driver. Please use your browsers development console to determine the root cause of the failure. Common reasons include the database being unavailable, using the wrong connection URL or temporary network problems. If you have enabled encryption, ensure your browser is configured to trust the certificate Neo4j is configured to use. WebSocket readyState is: 3

I uncommented this line in neo4j.conf file and tried , still I am getting same error.

added https://:7687 to exception by hitting this url directly from browser.

No success as of now. Can you please help?


in my case it was firewall issue(on my testbox), post my centos server restart firewalld service restarted. So i disabled it permanently. You can check below areas

Troubleshoot Neo4j browser issues:

-check firewall is disabled

service firewalld status
systemctl disable firewalld

-check owner/permissions on below paths

chown -R neo4j:neo4j /var/lib/neo4j/data /var/lib/neo4j/plugins /usr/share/neo4j/lib /var/run/neo4j /var/lib/neo4j/metrics /var/log/neo4j 
chmod -R 777 /var/lib/neo4j/data /var/lib/neo4j/plugins /usr/share/neo4j/lib /var/run/neo4j /var/lib/neo4j/metrics /var/log/neo4j 

-check non-local connections are allowed or not


PS: All (or) some of the above settings may not be recommended for PROD boxes.