First time install, cant connect using chrome

hello, i am trying neo4j for the first time, downloaded and installed Neo4j Desktop 1.3.4, gave it my app key. It starts the Movie Database. I use "load-movies.cypher" to load the database (using "Open with Neo4j Browser", and can use the Neo4j Browser app to play with the data. I then try to browse the database with Chrome web browser. I tried linking to http://localhost:7474/browser/ (and other ports), it prompts me for a Username and Password. I've read elsewhere these are default to neo4j / neo4j, but It always gets " Neo.ClientError.Security.Unauthorized: The client is unauthorized due to authentication failure." when i press Connect. In Neo4J Desktop i can see the logs, e.g.

2020-08-28 21:04:45.624+0000 INFO  Sending metrics to CSV file at D:\Documents\Neo4jDesktop\neo4jDatabases\database-e697c230-623f-4001-a873-495f1ce43431\installation-4.1.0\metrics
2020-08-28 21:04:45.649+0000 INFO  Bolt enabled on localhost:7687.
2020-08-28 21:04:46.518+0000 INFO  Remote interface available at http://localhost:7474/
2020-08-28 21:04:46.518+0000 INFO  Started.
2020-08-28 21:07:27.622+0000 WARN  The client is unauthorized due to authentication failure.
2020-08-28 21:07:28.235+0000 WARN  The client is unauthorized due to authentication failure.

Why doesnt it connect via the web browser? What is the default username / password? Thanks

1 Like

fyi i also tried updating the Settings as follows

# The address at which this server can be reached by its clients. This may be the server's IP address or DNS name, or
# it may be the address of a reverse proxy which sits in front of the server. This setting may be overridden for
# individual connectors below.

# You can also choose a specific advertised hostname or IP address, and
# configure an advertised port for each connector, by setting their
# individual advertised_address.

# By default, encryption is turned off.
# To turn on encryption, an ssl policy for the connector needs to be configured
# Read more in SSL policy section in this file for how to define a SSL policy.

# Bolt connector

# HTTP Connector. There can be zero or one HTTP connectors.


So the answer to this lies in the about-movies file, which will launch an informational slide about the movies db. On slide 13, it covers security, and mentions that the sample database was initialized with a random password for the neo4j user, and that Desktop is remembering your credentials for you, so that explains why you're unable to launch this via your browser, but have no trouble when you open it via Desktop.

It also provides info on how to reset the user password using the Manage panel for the Movies Database (click on the ... in the upper-right corner for the database card, then click Manage). The last tab here is Administration, which allows you to reset the password from within Desktop.

That said...there may be a bug in the current version of Desktop which may be interfering with the password reset feature. If you can get it to work for you, great! If not, let us know, it is being investigated.

To workaround, stop the Movies Database from within Desktop, and add a new Database (there should be a blank card area next to the Movies Database for this), select the title and version of Neo4j as well as the password, and use that instead.

Once you get it started, you can click on the load-movies.cypher file which will copy the Cypher to create the data to your browser, and after running that, your copy of the movies database should be up and running.

1 Like

thank you for the quick reply. Creating a new database as you suggested works fine now!

I suspect I have encountered the bug you mention. Resetting the password on the original database results in a new prompt for "Local Graph password has been changed. Please enter Graph password:" where my new password gives error "Failed - not a valid password.".