Failure running gds.graph.create

I'm using the following
Neo4j Browser version: 4.0.5
Neo4j Server version: 4.0.2 (community)

I am starting to use the gds library. The first thing I tried was gds.graph.create and ran into an error. I'm using the example from the documentation:

CALL gds.graph.create(
YIELD graphName, nodeCount, relationshipCount, createMillis;

I created two nodes (:person) and one relationship (p1:person)-[:LIKES]->(p2:person)

When I ran the create graph procedure I get this error:

Failed to invoke procedure `gds.graph.create`: Caused by: java.lang.NoClassDefFoundError: Could not initialize class org.neo4j.graphalgo.config.GraphCreateFromStoreConfigImpl

I checked neo4j.log and debug.log and didn't see anything relevant there.

Hello @davidmakovoz,

Which version of the GDS library did you installed on Neo4j Server?
You must use: GDS 1.2.0 (GitHub - neo4j/graph-data-science: Source code for the Neo4j Graph Data Science library of graph algorithms.) :slight_smile:


Thank you, Maxime!! It solved the problem.

1 Like

Nice, no problem, I'm happy to hear that:)

How did you resolved this issue, I'm also facing same error.

I'm using GDS version - 1.5.2 and community - 4.2.5

#Check for appropriate version for neo4j and GDS library from that git file

# first create a node and relationship
create (:Person{name:"Oliver Stone"})-[:LIKE]->(:Person{name:"Karan Kajrolkar"})

#Then try to create native projection

CALL gds.graph.create(
YIELD graphName, nodeCount, relationshipCount, createMillis;



"my-native-graph"|2 |1|51|