'Failed - not a valid' right after resetting password

When trying to change the password of any of my databases with the reset database password button under Project>somedatabase>(three dots)>manage>Administration tab, the password does not seem to change into what I choose and it doesn't default back to neo4j.

When I restart the databse, I get the following problem when I try to enter the new password and press save .

but the ignore button still works and bypasses this problem, for now. Then I want to open the browser and login with my new password, but it doesn't work and I get the following error.

I don't know how to continue, I've looked at several posts and tried multiple things. I should have taken notes along the way. I feel like reinstalling Neo4j Desktop would be the best thing at this point, but I hope to fix it the proper way...

I looked at this:

I can't find data/dbms/auth or data/dbms/roles

and then I found this:

Don't know how to get into this shell so I looked it up and found this

But no clue where to find <$NEO4J_HOME>/bin/neo4j-shell.... Even when using 3rd party search tools to search my whole PC for anything *neo4j* *shell* How can I open the shell? If it is not available how do I install it? Do I download it here ?
And then create a bin dir in C:\Program Files\Neo4j Desktop\, place it there?

Windows 10 version 2004
Desktop vesion 1.3.8
Neo4j version 4.1.0 and 4.1.2

Hello, I had a similar problem.
I couldn't start the database because of the same error message.

The recovery was pretty simple:
Disable authentication in your settings by setting:


Then all you have to do is to go to your Neo4j Browser and paste this into the shell:

ALTER USER neo4j SET PASSWORD 'mynewpass';

1 Like

Thanks for your response! At this moment I can't try out your solution, but I will try it soon! I'll let you know if it worked.

I did as you said and then turned bdms.security.auth_enabled back to true, and it worked! Thank you very much. The problem was following me even when I made new databases and when I had removed all the other ones.

1 Like