ETL stucks at Mapping - No error

Hi all,

I am using Neo4j Desktop and I want to create a mapping between a remote DB (Postgres) and my local Neo4j Graph DB.

For that, I am using the ETL Tool. Three days ago, everything worked fine and I was able to import data from Postgres and save it into a graph database (the whole process took around 30-40 minutes).

Without doing any changes, I tried to re-import the online DB yesteday but ETL stucks at "Mapping..." (for at least 1 day now) without providing any error messages.

I am using:

  • Neo4j desktop 1.4.1
  • Graph DB Version 4.2.1 enterprise (tried with 4.2.3 as well)
  • Neo4j ETL Tool 1.5.1

Thank you for your help.

Are you trying with the same DB or with an empty one?

If you mean the local graph DB, I deleted the previous instance and created a new one. As for the remote, it is the same DB as the one I already managed to map three days ago.

Can you please check within the Postgres database if something happend? Because if it worked once I don't think the issue is related to the ETL tool

Hi, in general, the Postgres works fine (I was able to fetch data from it just now). Should I check anything specific?

You can check into neo4j.log and debug.log for exceptions

Hi again and thanks for trying to help. Unfortunately none of these files include error codes or something that could help me understand the problem.

Can you share the mapping file?

Unfortunately not. It is a private DB. Do you have an estimation of the max amount of time a mapping can take for a database with Gigs of data?

the mapping file is stored into you local machine you can find it on top at the log inside the ETL

First of all, sorry for the late response but I was trying to identify the issue by myself. I examined the mapping file but I, unfortunately, cannot share it as it contains table information of the live DB. However, no error were mentioned in this file.

I copied the liveDB to my localhost (in case there was a connection issue with the server) but nothing happened. I even performed a clean installation of the Neo4j Desktop but the issue remains.
It currently runs for 2 days but it is stacked in the "Mapping..." message.

*Forgot to mention that the .json file was last updated yesterday on the 25th of February

Maybe you can try by using the last Postgres JDBC driver.
You can download it from here:

Unfortunately it still shows the same message. Could this happen because of the size of the postgres db?