Errors when importing local database to Aura

When I want to import the local database in the neo4j desktop, I follow the steps on your website. Open commanding line, input "neo4j-admin help push-to-cloud". It says Unknown subcommand push-to-cloud.

So I follow the step and download the 'push-to-cloud' file and put it in the lib folder. It still doesn't work.

So I give up the commanding line and download the Neo4j Cloud Tool.
I can connect to the remote Graph successfully.

I can check the existing cloud database. I can even query node in Aura.

But when I import the local database or even dump file, it fails again.
I don't know how to fix that.

Hi there,

After you install the push-to-cloud command run this command in the terminal then share the output with us:

bin/neo4j-admin help push-to-cloud

Also, what is the version of Neo4j you are trying to import into Aura? It looks like you may be running Neo4j 4.0 but I want to double check. At this time, Aura is not compatible with Neo4j 4.0, so you'd have to export your data into a 3.5 graph before using push-to-cloud to import it into Aura.


The version is Neo4j 4.0.
So I create another database. The version is 3.4.17. The push-to-cloud works.
But when I begin to import the local database, it shows these errors.

I also tried the neo4j version 3.5.14, it shows the same errors.
My desktop version is latest.


push-to-cloud won't work on an active database, it has to be shutdown first. If it was shutdown then it's likely it was not done so cleanly. Please start the database as a standalone, then shut it down either by running bin/neo4j stop in the directory where your database is installed, or by using Neo4j Desktop to manage the database and clicking the stop button in the management window.

After the database has stopped cleanly please try the push-to-cloud again.


I am pretty sure I shut down all the database.

It still doesn't work.

I also find one thing.
If I go to neo4j database version 3.5 and try to dump the database, it shows neo4j database doesn't exist. Actually, I have already create the database in the neo4j desktop.

But when I run the same command in neo4j 4.0, it works successfully.
If I use Aura to import dump file which exported by neo4j 4.0, it says it is not a dump file.

But since I can't get the dump file from the version 3.5, I can't have a try by using import dump file in Aura Cloud tool.


Let's move this to our support portal where you'll be able to securely upload logs and related materials. Please open a case at and I'll pick it up there.

When you do, please include the following:

  • The neo4j logs from the 3.5.14 database (zipping the entire log folder and uploading the zip file is best).
  • Run a consistency check on the database and upload any output.
  • Confirm the steps taken to stop the database. Did you use Desktop to stop it or did you run neo4j stop in the console?


Thanks for your help.
I use desktop to start and stop it. When I go to commanding line and run "neo4j status", it says the database is stopping even I have started the database in the desktop.

I have opened a case and upload the log file.

When I run a consistency check, commanding line says "Could not find or load main class org.neo4j.consistency.ConsistencyCheckTool"

So I can't upload the output of consistency check.

Hi Feng,

My apologies, I gave you instructions for an older version of Neo4j. Newer versions, like the 3.5 series that you're using, has this feature built into neo4j-admin. The full instructions are in our docs, but the short version is to run:

bin\neo4j-admin check-consistency --database=graph.db

Please try that command then run the import once more. You can reply either here or on your ticket in our support portal if you encounter any other issues.