Empty sysinfo response on 4.0.4

Upgraded to 4.0.4, using the web browser interface.

When running ":sysinfo" query, I get an almost empty response. This is different from what I would have gotten back on v3.5.0.

I get the same type of issue when running commands from this blog post: How to generate sysinfo output from Cypher - Knowledge Base (v3.5 would output the same type of data, v4.0.4 comes back empty).

Is this a feature change in 4.0.4, or something that was moved out of the Community Edition, or is it just me?

This is a sysinfo on a almost empty 4.0.3

The fact what no numbers are displayed make me think something is not ok on your end..

Thanks for confirming it could work Paul. I took a step back, tried to run from the base docker image, with the instructions, and still get the same issue (tried 4.0.4 and latest tags). Could it be something off with the Docker image?

docker run
--name testneo4j
-p7474:7474 -p7687:7687
-v $HOME/neo4j/data:/data
-v $HOME/neo4j/logs:/logs
-v $HOME/neo4j/import:/var/lib/neo4j/import
-v $HOME/neo4j/plugins:/plugins
--env NEO4J_AUTH=neo4j/test

Same issue with Community Version 4.1.0 on macOS Catalina. Database populated with > 30 million nodes and 300 million relations but not a single entry when querying :sysinfo

Does anybody found a solution for this?

Any help to fix this greatly appreciated


So I guess that :sysinfo is no longer supported on Community Edition per github issue:

I got the same issue in enterprise version 4.3.0, have you resolved this issue yet?

In your neo4j.config file, please double check that the following configuration option for allowing metrics exists and is enabled.