Database 'neo4j' is unavailable. Cannot reset neo4j database

I have my community 4.1.1 neo4j service installed on the ubuntu commandline running on my windows machine. I have been using neo4j steadily for a month or two now, just recently it has prevented me from accessing the neo4j database:

Database 'neo4j' is unavailable. Run :sysinfo for more info.

I have tried uninstalling neo4j and reinstalling but that has not worked either. I tried playing around with the default listen address previously, but now with the reinstall all config data is back to normal. Running ./cypher-shell under bin does not work. It says:

Unable to establish connection in 3000ms

If I run ./cypher-shell -a it says:

Database 'neo4j' is unavailable

I am truly stumped. Anyone have any advice on how I navigate this issue?!

Image below showing failure to create new db (which I understand why it is community edition but it just hangs and fails as opposed to saying 'cannot create db in community edition')


Running into the same issue. Restarted the neo4j db and am receiving the error
Database 'neo4j' is unavailable

I can switch the default database to something like neo4j-test and it will connect but using the original neo4j db will not.

Found this out a while back. All was required was ending processes for port 7474 and deleting db (maybe you might not have to delete db Im just testing right now so the data didnt matter). Connection to port 7474 in browser was not immediately failing so that means it was hanging. Attempting to end processes with taskkill did not work so it required me to download "Process Hacker". Run netstat -ano | findstr :7474 in command line. End all matching processes found from command in process hacker. Delete neo4j db if needed under neo4j-community/data/databases/neo4j (or backup if you want) and then run neo4j again.