Database import strangness

Hey everyone, I've been wanting to import a database dump from another laptop and forever reason the dataset is completely off...

the labels are not all there and the node and relationship count are not the same.

I do have another database in the same DBMS and it seems to be recreating that other database instead of the one I want.

I have double and triple check that I clicked on the correct database to dump but it's still importing inaccurately.

Anyone else having the same issues?

Can you walk us through the steps you are doing?

Hey Michael,

Here are my steps as best as I can describe them:

  1. click dump from database option
  2. upload dump to google drive
  3. download dump to separate computer
  4. import database via dump

also, I even tried loading the dump to the same DBMS and even that didn't replicate the database accurately.

any help would be greatly appreciated!

  1. Stop the server
  2. Click on 'Terminal' from database option
  3. Run this script:
    bin/neo4j-admin dump --database=xyz --to=data/dumps/neo4j.dump

4, Once it's done, run this script
bin/neo4j-admin load --from=data/dumps/xyz.dump --database=xuzz --force
5. After completion, start the server and open the browser
6. From database dropdown select 'System' database
7. Run this: CREATE DATABASE xyzz
9. Check to see if the database XYZZ has 'online' status under requestedStatus column
10. Finally, select xyzzy database from dropdown.

1 Like

Worked like a charm! Thanks!

Now I just need to somehow move the dump file between the devices and used the second command on the computer to load it

Good to know that it's working. Yes, you can copy that dump file and make sure that you insert into data/dumps folder in the other machine..

1 Like

yep, working beautifully. :+1: