Database Error

I am getting the following error:

"Database failed to create: Error: Could not change password"

through what command was run to generate this error? Do you have more details of the steps leading up to this error?
Did you run


or similar? if not what was run ?

I tried to update the Neo4J version and then since none of the database were working I tried reinstalling the Neo4J desktop version. It is since then I have been facing this error and I am unable to create a graph database.

if you reinstalled??? perhaps the default password for the neo4j user was reset. The default is neo4j try authenticating with that. and if you are then able to connect you would need to change the password with


replacing newPassword above with a password value of your choice

I will try that and let you know. Thanks.

I am getting this when I am trying neo4j as password

Otherwise the error is this when I am trying to create a new graph.

I tried downloading the software on another machine and it works on that (however I do have problems working graph algorithm app and Neo4J browser by copying the codes and using it in Neo4J browser).
I did try and uninstall the software from my machine and re-install it but some user files remain. Is there any way I can clear all the user files related to Neo4J before wiping of my system and then reinstalling it?

if you are having issues with authentication, the files at data/dbms/auth and data/dbms/roles describe the users and roles respectively. Stop Neo4j and remove/move said files and if you then restart Neo4j the files will be created a new with default user of neo4j and default password of neo4j

I have tried changing the path of database but it’s not working. The last option is to completely wipe off my system and reinstall the windows. Is there anything that I can do to clear all Neo4J files and reinstall the desktop version?

My guess is this is a powershell error. Is this your laptop, or does it belong to an enterprise domain that controls your among other things your group access controls?
What version of Windows?
Try opening a powershell window and run $psversiontable at the prompt. What does it say?

Hi David,

I am using a system belonging to enterprise domain. Yesterday, @ameyasoft suggested a solution of deleting the folder and it did work. On checking the configuration file, I found that the path to which I was being directed to was wrong.

Thanks once again for all the help and support.


I am facing the same issue while using the neo4j desktop. I am using AppImage version on Ubuntun 18.04.

Any suggestions?

Check the log file and look for this "Failed to fix all running databases Error: ENOENT: no such file or directory...." After this you will see the path to the database folder. Check to see if this folder exists in your installation folder.

Let me know.

As I mentioned I am using AppImage, AppImage runs as a standalone file. It does not have any installation folder. I can not see these details using AppImage.

this is what i get when i run the AppImage via terminal.