Create multiple graph in community version

Hello,

I am new to Neo4j, I need to create multiple graphs in community version.
When i execute CREATE DATABASE xxx; i have this message Unsupported administration command because i am with community version.
How can i create new graphs like in desktop version image
I want to know if we can do that in community version also. If so, can you please provide how to do it.

Thanks

2 Likes

You're going to need to make sure you're using 4.0 enterprise. You can find examples of all the stuff you're asking about here Managing Multiple Databases in Neo4j - Developer Guides

1 Like

The word "enterprise" does not appear on either of the following pages. Are you sure 4.0 Enterprise is required, or can this be done in 4.0 Community as well?

All I can tell you is that I’ve tried this operation on both community and enterprise editions and it only works for me on enterprise. But you are correct they don’t have that in the documentation for sure.

Thanks. I did find a page that indicates it's Enterprise-only: https://neo4j.com/docs/cypher-manual/4.0/administration/databases/#administration-databases-create-database

1 Like

Thank you for your responses,
So it is not free to implement multiple graph ?
Another question is: can i change users roles in community edition ?

While you can try out Enterprise Edition with Neo4j Desktop (which allows dev only usage), you would need to have a license for production enterprise usage, and there are potentially some free paths to this with startup, academic, or evaluation licenses.

While we also have Neo4j Aura for db as a service, we are ramping up for 4.0 support (not available just yet), and role assignment and handling is likewise being built out.

For community edition, while users can be added, but roles cannot be added or changed.

It'd be great if the docs at Managing Multiple Databases in Neo4j - Developer Guides were updated to indicate clearly that this is an Enterprise-only feature -- I believe I'm not the only one who spent time trying to "debug" this.

8 Likes

Yes, that makes sense, I'll pass along the request to the docs team.

1 Like

hours, many hours lost, to understand among cryptic error messages from cypher-shell that I cannot grant privileges or stop database using community edition.
I love neo4j, but this is quite harmful behaviour. Neo4j tools should spit out nice error messages like :" this feature is not available in community edition".

4 Likes

I just downloaded Community Edition and one of the very first things I tried to do was setup and create a new database, following the docs on neo4j.com....Hours later I ended up on this helpful thread.

It's very frustrating that the docs (and error messages) don't mention this is an enterprise only feature. I'd imagine setting up a new DB is one of the first things people test driving Neo4J do, so this issue really sucks in particular

1 Like

@manbradcalf
I dont deny having an error message reporting a message to indicate the error is as a result of being enterprise only functionality but the documentation at Database management - Cypher Manual does indicate

3. Creating databases   [Enterprise Edition]
Databases can be created using CREATE DATABASE.

Ah, fair enough, however a quick Google search of “Neo4J create database” led me here: Managing Multiple Databases in Neo4j - Developer Guides

…which doesn’t state directly that enterprise is required, instead it only leads me to a link about Neo4J desktop, which I’m only now learning is a local-only version of enterprise

I’ll admit I might not be the most thorough doc reader and I skimmed the docs there a bit, but I doubt I’m alone.

1 Like