Connection Refused error but it use to work fine?!

Hi all,

I installed neo desktop and was working fine but now I have started getting connection refused error message?

I also am having same error message connecting through the .NET GraphClient. I have tried all of the following:

//await neo.Connect("bolt://localhost:7687", "neo4j", "neo4j");
//await neo.Connect("http://localhost:7687", "neo4j", "neo4j");
//await neo.Connect("http://localhost", "neo4j", "neo4j");
//await neo.Connect("http://localhost:7474/db/data", "neo4j", "neo4j");

my Connect function is below:

public async Task Connect(string uri, string username, string password)
//GraphClient = new GraphClient(new Uri("http://localhost:7474/db/data"), username, password);
GraphClient = new GraphClient(new Uri(uri), username, password);
GraphClient.OperationCompleted += _graphClient_OperationCompleted;
await GraphClient.ConnectAsync();
return true;

I have also tried using no authentication but that didn't work either.

What is odd how the desktop browser stopped connecting too. How do I find out what the username and password is?

Also what is the URI to connect through code?

I found this link to reset the password but couldn't get pass the first step because it looks like its for Linux and not PC?

So obviously the command was not found.

Any help would be really appreciated.

Many thanks,