Cloning a database "destroyed" it?

I've simply made a clone out of my simple, 7k nodes, 4.1.1 db, using NEO4j Desktop 1.3.8

Now it (the initial database) cannot start due to "Database failed to start: Error: Relate DBMS with tag neo4j-desktop-dbms-database-ebd9c666-56f7-49ea-b484-0c6b01a8259c not found. Check the logs"

Logs are not even updated, by the way - i've opened the logs folder from Neo4j Desktop and looked for the last change time - half an hour ago, whereas i have been trying for the last 5 minutes to start my db.

The folder ebd9c666-56f7-49ea-b484-0c6b01a8259c is still there so I wonder what happened.
To me, it should be something in the config files....

1 Like

Ok, so, the reason logs are not updated when trying to start the application is because the logs of the original database are actually written ... by the clone..... :face_with_raised_eyebrow: ....whaaaat?

If opening the logs folder from setting, the name is different, but i guess the reference (shortcut??) is pointing to the same folder, as the content, the files, are identical in "both" folders :

Clone: Trying to open C:...\AppData\Local\Neo4j\Relate\Data\dbmss\dbms-3c4a8ac3-a8bc-4eb0-8629-5e8389e937b8\logs directory


Original: Trying to open C:....Neo4jDesktop\neo4jDatabases\database-ebd9c666-56f7-49ea-b484-0c6b01a8259c\installation-4.1.1\logs directory

I guess it worked on Linux, but it does not on Windows.

Hey @gabriel.toma,

Thank you for the report. This sounds like a bug, almost as we're copying the symlink instead of the whole directory in some cases when cloning.

Just to confirm this, is the clone able to start? Did you create the original DBMS with 1.3.8 or with a previous version? Can you reproduce the issue if you try creating a new DBMS (with 1.3.8) and cloning it?

Thank you,

I've created the db with 1.3.6, i think...definetively where was an update to 1.3.8 while i was working with the db.

Couldn't reproduce with new db (desktop 1.3.8, neo4j 4.1.1) : I created 1 new db and created 2 nodes/1 relatioship: cloned it while running, cloned it while stopped: all 3 of them start.

Ashamed that maybe a have raised a fake alarm, i took the courage to do another clone of the full db: the clone of the clone starts whereas the original clone can i describe this...when i click on start, nothing happens.

Otherwise, i can use the menu "..." to reach manage, starting from there still does not work
I just click and nothing happens: you can see the slight difference in shading of the background color of the start button...
image image
(veery slight difference, but i do not have any other way to show it)

Ah, wait, i've closed and re-opened Desktop :

At least the clone of the clone - which i think it's the original - starts :slight_smile:

May be something different than just copying the symlink: I cannot even find anymore the initial symlink/folder of the original db

This seems to confirm my suspicion.

The fact that it's not reproducible with a new DBMS makes sense as in that case we have a folder and not a symlink in the Relate folder (the one you posted a screenshot of in the end).

It's also normal that you don't see the ID you're looking for in the Relate folder as those IDs are different than the ones used by Desktop.

The good news is that your DBMS is safe. At a high level what's happening is that instead of being cloned your DBMS is getting a new ID and name, so as you said the original installation is now the clone of the clone. This bug should affect only installations before 1.3.8.

A workaround until we get this fixed would be to replace the shortcut to your DBMS with the directory the shortcut is pointing to, just make sure to preserve the naming (the one used by the shortcut) and don't modify the content inside it.

Thank you again for your valuable feedback!

The fix for this bug is available starting from 1.3.9.

1 Like

I have the exact problem. My installed version is 1.3.10 but there is nothing fixed.

@mahdi what steps are you taking to reproduce this bug?

I tried to clone a new DBMS, one created with 1.3.4, cloning a clone and they all seem to work on 1.3.10.