Can't create new local database in desktop project

When I try to do an "Add Database" in a Neo4j Desktop 1.3.4, I get the following error:

"Database failed to create: Error: Not enough memory resources are available to process this command."

If I try to create a local database a new folder with the GUID of the database is created, but it won't show up in my project folder, even thought it actually created a new db in the users.Neo4jDesktop\neo4jDatabases folder

If I try to create a remote database I get the same error and the database definition stays there when when close and reopen neo4j desktop, but the password won't save. Every time I try to save the password, I get the same error.

I found that if I remove a database from the project folder and then immediately try to Add one, it works, but only right after I remove one. If I try to add another one, or exit and open desktop again, I get the same error.

I can see in the log file that it created the db and changed the neo4j password, but the log doesn't show any errors.

I suspect this is some type of java limit or threshold setting, but I'm not sure where or how to change it to fix it.

Hello @bryant

What is the power of your computer? Which OS?
Did you try to uninstall / install?


Thanks for the reply @Cobra. I have a Xenon processor with 64GB of RAM and 4TB of hard drive space. It's pretty much a server-grade laptop running the latest updates of Windows 10. So it's definitely not a resource issue.

I have uninstalled and reinstalled and after creating about 4 or 5 separate local databases it won't let me create any more or link to a remote DB any longer and I get that message. Now I haven't uninstalled real recently, but I have since I started having the issue. It's been going on now for several months and I just finally decided to see if anyone else was having the issue or not.

That's why I'm thinking it must be some type of configured java or registry setting or something that's limiting it. Typically after I reboot, I'm able to add 1 new database but then get the same issue every time.


To be honest, I have never seen this problem.

Are you using Windows Server or Windows Professional?
What resources do you allocate when you create a local database?