Cannot log in to Graph Academy

I cannot sign in and use Graph Academy, everytime I try I get the error 'Error while loading the data, please refresh the page.'

I have tried three different browsers and restarted and updated my computer and I have refreshed my cookies. Nothing is working. Does anyone have a solution?

1 Like

Hello @victoria_nugent,

Welcome to the Neo4j Community!
What Web browser are you using?

Make sure that your Web browser does not have an extension enabled such as an ad blocker. This could be preventing the page from loading.

If you are using Firefox, there is a new feature in Firefox called Enhanced Tracking Protection that blocks sites. Can you temporarily disable it?

Most users have no problems when using Chrome. In some cases using an incognito window is a solution.

For whatever browser you are using, please clear all cookies and cached pages also.
Also check if you are using a VPN or firewall that could be blocking access.

We also use tracking cookies for which you must accept.

Let us know if you continue to have problems with access.

@victoria_nugent ,

I was able to reproduce the error - we are looking into it.


@victoria_nugent ,

You should be able to log in to Graph Academy now.


I am also facing the same error. I tried incognito, removing all extensions as well. It isn't working for safari and chrome both.

Hello @parthiv3215 and Welcome to the Neo4j Community!

We had a problem on our end that has been resolved. Please do let us know if you still have trouble with access.


Dear Elaine, thank you for your prompt reply. I had a few questions regarding a project that I am working on that I believe you might be able to help me answer. Is there any way I can reach out to you on call if possible ?

Thank you for your consideration

Hello @parthiv3215 ,

Unfortunately, we do not provide phone support, but if you have a specific question about Cypher or graph data modeling, please post it in this forum in the appropriate discussion areas so that others can see it and benefit from the answer(s) you receive.

We also have a discussion category for new users:


Hi Elaine I am getting this issue right now 'Error while loading the data, please refresh the page.' is this an ongoing issue right now because incognito also does not work for me

Hello, I am also having this same issue. I have tried several browsers and removed all extensions.