Cannot launch Neuler despite running db and graph algo plugin installed

Neo4j Desktop 1.2; Neuler 0.1.12, Neo4j 3.5.6, algo.* enabled in db setting

Upon clicking on Neuler it attempts to connect, however, get's hung-up with message:

The application relies on Graph Algorithms plugin. You can install it via the plugins tab in the project view.

It did work for a completely new installed database that is empty.

Any suggestions of what I might be missing?

Thank you.

Have you checked the plugins tab for that database, and ensured the graph algo plugin is installed?

Yes it is installed, even tried to uninstall, delete and reinstall, so far to no avail. Will attempt other things too see whether it would fix the issue.

A new install of an empty database from scratch worked fine. Might have to consider doing that for my older databases, those that were already there.

If you can start the database, can you do a sanity check and see if the graph algos are indeed loaded and usable?

You can use return algo.version(), which should provide the version of the graph algo library being used, if it loaded properly.

This is what I found running this command, indicating that it simply doesn't see the plug-in.

Neo.ClientError.Statement.SyntaxError: Unknown function 'algo.version' (line 1, column 8 (offset: 7))
"return algo.version()"

I was able to fix the issue, though, by copying my graph.db folder from the project where altos DONT work into the project where I got altos to work. Once I did that I was able to connect to Neuler fine and run some algos.

Maybe that helps understand what might be happening. At least I know a workaround now.

Thank you for your suggestions!

altos = algos = algorithms :upside_down_face:

You may want to check permissions for the plugins folder on the project where it's not working, you want to make sure whatever user is used to launch Neo4j also has read permissions into the plugins folder.

Also you'll want to check your Neo4j and graph algo versions. Maybe the one that isn't working is using the wrong graph algo version for its Neo4j version? Are the two dbs using the same version?

I am unable to use the codes produced by Neuler app on the Neo4j browser. It is showing an error. Any idea as to why?

I am getting the following error:
Invalid input ':': expected whitespace, comment, Statement or end of input (line 2, column 1 (offset: 13))
":param relationshipType => null;" ^

I would try to use both relationship directions, I got it to work that way. You may have to push the code into the Neo4j Browser and then follow what happens there.
The application Neuler is a great start, but still seems to have some rough edges.

Hope this helps.

1 Like

I enabled the multi-query editor in Neo4j browser settings and it worked.