Cannot enroll in online training

I can not enroll in the online training course (neo4j administration). I get the following error:
"Submission failed, please try again later."
Any ideas?

Hello Ari,

The site seems to be up and running. Can you try again?

We do use tracking cookies so they must be enabled and also make sure you have no ad-blocker extension installed in your browser.

What browser/version are you using?


Hello Elaine,

I am using latest version of Chrome & Win 10. I didn't have any problems a couple of weeks earlier when I did the introductory course. But actually, that was within neo4j browser...

I have disabled Ghostery, cookies should be enabled as well.


Ghostery was the culprit. I'm all good now. Thanks!


I got proper enroll form only from Microsoft Edge, neither Firefox nor Chrome (tried disabling adblocking - no effect) worked.

Welcome to the Community!

That's strange, typically Chrome works for everybody. There must be another extension installed that is blocking. I am glad to hear that you were able to continue with the enrollment with MS Edge.

Good luck learning Neo4j.


I am having similar enrolling issues since the last 24 hrs. It was working from chrome but now every-time I try to sign in it gets me back to the sign in page and does not login. Any ideas?

Hello Vikram,

We have a certificate problem on our online training site that we are in the process of resolving.

We hope to have it resolved soon.

Elaine Rosenberg

1 Like

Thanks Elaine!
Same issue here with Chrome. Shall wait for resolution and try again later! Thanks

The issue with our online training site has been resolved.

Please do let us know if you have problems.


I am having a similar issue on FireFox (I have disable ad blocker and accepted cookies). When I try to click on the Sign In it doesn't redirect me and nothing happens, even if I try the other online courses.
URL: Neo4j Fundamentals | Free Neo4j Courses from GraphAcademy
But it works for the Become a Neo4j Certified Professional.
However I don't have this issue on Chrome or Edge. It is a bit of nuisance to use chrome since i use Firefox as my default web browser.

Firefox has added more security to their browser. They have ETP and by default, it is set to STRICT. If you set it to normal, it should work for you, or even disable it while you are in the course.

Ad blockers will also present a problem for you with access.


1 Like

Hey Elaine,

I am having the same problem. I have been trying to enroll in the Introduction to Neo4j training but the sign in button does not work. I have tried on Google chrome and MS Edge also in incognito modes. The google chrome console gives me an "Uncaught RangeError". Cookies are enabled and no ad-blocker extension is installed.


Welcome @alihussain17 to our Community!

Double-check that your Web browser does not have an extension enabled such as an ad blocker. This could be preventing the page from loading.

Also check if you are using a VPN or firewall that could be blocking access.

We also use tracking cookies for which you must accept.

Can you provide a screen shot of what you are seeing in the console?


Thanks for the response. I have attached a screenshot of the console. I don't have any ad blocker extension. Also not using any VPN.


Thank you for the console log, it helped us to diagnose the problem on our end. It is now fixed.

Let us know if you encounter further problems.


Hello @robbdunlap and welcome to the Community.

The course, Introduction to Neo4j 4.x has been replaced by the 5 courses shown. You can enroll in any of them. If you go through all 5 of them, it will be equivalent to going through the 2-day Introduction to Neo4j 4.x course.

That is why you cannot enroll in the "Series" course.


1 Like

Hello! I also have an issue to enroll the course ' Learn about Indexes and Query Best Practices in Neo4j 4.x'. Yesterday there were no issues.

Hello @rybakm ,

We had a problem with one of our internal systems which has now been resolved.

We do apologize for the inconvenience.


Thank you, @elaine_rosenber !