Cannot create new database from dump-file

I'm in the online training "Applied graph data science for web applications".
Download of the dump-file "yelp-40.dump" was successful. Import in the new project (Yelp) was successful. When I click the 3 dots of the file-area, there is no menuepoint to create a new database from the dump-file.
What's going wrong?
These are the menuepoints I get:

Asked and "solved" here...

thanks a lot, it seems I have to wait...

i'm pretty bummed, too

One solution would be for you to use the neo4-admin tool to create the database from the dump file.

  1. For the started DBMS (must be the same version as the dump file), select the terminal window for the started DBMS.
  2. Type the following to create the database: bin/neo4j-admin load --database= --from=
  3. Then in Neo4j Browser:
    :USE system

Hopefully that will work for you.

1 Like

Dear Elaine @elaine_rosenber & Neo4j team,

I'm also facing the same issue (cannot create new database from dump file). I tried your solution, but I'm getting error message "bin is not recognized as an internal or external command". In general if I use cmd, I can overcome this error by adding the path to environment variables, but since I'm using Neo4j terminal, I'm not sure how to handle this, could you please help me out, thanks.

Have you opened Terminal from an existing DBMS?

In that window, there should be a bin folder.

What is your platform?


Thanks for responding. I'm using Windows 10. When I selected Database-->Open Folder-->DBMS. It takes me to the folder directory and I could find the bin folder inside it.

I've created a new project named "Yelp Project", then uploaded the yelp dump file in it, however I'm not getting the option "Create new DBMS from dump"(unfortunately that feature is not available in desktop version). So I selected Add --> Local DBMS and created a database. But when I open Neo4j Browser, there are no nodes and relationships. Are there any other ways to load the data from dump file? (kindly refer below snapshots)

Do you see a bin directory? (dir command)

What if you type ./bin/neo4j-admin....?

The other thing that could be a problem is the directory name that is blacked out. Does it contain a space? Sometimes java processes don't handle paths with spaces.

You must specify a name for the database and the from file must be the absolute path to the dump file.


1. You created a new placeholder for Yelp database. If you open the db in browser you will
 see neo4j and system databases.

2. Database-->Open Folder-->DBMS. Here you will see data/dumps folder 

3. Copy yelp-41.dump file to data/dumps folder

4. Close the browser. Click on ... and select Terminal.

5. Terminal window shows up. Enter this command:
bin/neo4j-admin load --from=data/dumps/yelp-41.dump  --database=yelp-41 --force

6. If successful, close the Terminal window and open the db in browser.

7. Click on the database icon on top left to see the databases from the dropdown box. 
Here you will not see yelp-41 db.

8. Select 'system' database. On the right pane run this Cypher:
CREATE DATABASE yelp-41 and execute the Cypher.

9. Run SHOW DATABASES and you should see yelp-41 and check the status. Status should be 'online'.

10. Select yelp-41 from the dropdown list. Once selected you should see all the nodes, 
relationships on the left. Now you can start playing with it!! 

./bin gives "." is not recognized as an internal or external command.
/bin gives The system cannot find the path specified.
Finally I tried including the complete path and it worked.

Thank you very much for helping me @elaine_rosenber :smiley:

Dear @ameyasoft
I followed your steps and everything goes good.

Thank you very much for helping me :smiley:

@elaine_rosenber @ameyasoft I tried to load panama papers dataset in Neo4j desktop using the dump file, I followed all steps, but after creating the database, it says database is unavailable and status is offline. However when I check the import folder, the database was available inside it.
Can you please help me out with this, thanks.

You must specify that the creation is for a 3.5 database. Did you do that? You cannot have a 3.5 database created in a 4.0 Server.


My bad, the dump file is for Neo4j 3.5.14, but I created the latest database 4.2.5. Anyways there is no 3.5.14 version available in Neo4j Desktop :slightly_frowning_face:
Actually I would like to explore the Panama Papers dataset, I downloaded the dataset from ICIJ and loaded the csv files into Neo4j, all nodes were created successfully(there were around 754000 nodes, but when I created relationship, it was taking a very long time(more than 20 min, it was running), so I closed it and looked for some alternate methods to load the panama papers data.

Could you please suggest some other ways to load Panama Papers data into Neo4j Desktop.

You should be able to create the database from 3.5.14 dump file using the latest 3.5.x version in Neo4j Desktop. Does that not work for you?


I tried using 3.5.20, I'm not able to change the database to system, it shows no multi database supported. Also there was no dumps folder, so I created it manually and placed the dump file inside it. And in the terminal window, it shows you need to stop the Neo4j Database and run. I tried stopping database and run, but I got FileException Error.

I am using Neo4j Desktop 1.4.3 (on a MAC), hopefully this works on windows...

  1. Create a new project.
  2. Add dump file for the 3.5 database to the project.
  3. From the dump file select create DBMS from dump file.
  4. Enter a password (optional name), and select the latest 3.5.x release (I selected 3.5.27) - note that it will need to download that release.
  5. Click Create.
  6. Start the DBMS.
  7. Open with Neo4j Browser.


This way, the created database name will be the default 'neo4j'

I added the database to Neo4j 3.5.27 in the terminal successfully, then I opened the browser to create database using the command : CREATE DATABASE, but this command is not supported in version 3.5.x. I went through the Neo4j 3.5 user guides in Graph Academy and it says to update the configuration file, so I changed the dbms.active_database= graph.db to dbms.active_database=icij-panama-papers-35.db. After that it asks to Unbind all the nodes to clear the cluster state using "neo4j-admin unbind". I tried it in the terminal, but I get Database locked message. How can I overcome this?

Updating the config file: