Cannot connect to a database no matter what i do

Hello all.
I've downloaded Neo4j Desktop and am trying to connect to a database. Everything seems to be working correctly when i use the desktop app or the Neo4j Browser, but i cannot connect from any external source at all. At first i thought it was a Laravel/NeoEloquent issue, but i'm down to trying curl/postman and nothing works. If i query http://localhost:7474, it gives me a 200 response. If i query http://localhost:7474/db/data/ with some random credentials(or none at all), i get 401, which is expected. But if i input proper credentials, i get a 404. Is there some special way of getting stuff from the database that i don't know? Nothing i tried works, i created my own databases, imported examples. They all work in the Neo4j browser, but nowhere else.

Seems like this can be closed - i installed stefanak-michal/bolt and that actually worked. I'm probably doing something wrong with NeoEloquent, but i still cant understand hy i'm gettting a 404 with /db/data/ while every post on the internet suggests it should be a 200.

The endpoints have changed in 4.x. Please look at the http api.