Broken site in cypher online training

Hi, first post on here.

I'm trying to get into Cypher, and was reading on the Cypher dev page. It contains a link to 'Cypher Online training'
The site this leads to appears to be broken, however. It contains what looks intended to be a button to enroll in a course, but clicking it does nothing. Screenshot below.
Am I missing something or is this somehow the intended behavior?
I'm viewing the page in Chrome on Windows 7.

Hi welcome to the community
Did you try to refresh your browser

I did, with no effect. I tried looking at the underlying html, and it looks like the button is supposed to execute some kind of script, so my best guess is my company network is blocking that.
I'm following the course now on the same account, but a different machine on a different network, so the problem is probably unrelated to my account.

Ok good to hear and success with the course

I also ran into the same problem. I solved it by disabling an adblocker I had on my browser.

Sorry for digging up an old post. But I think since we are all cooped up in our homes right now and taking MOOCs a lotta people are going to run into this issue now! So hope this helps.

BTW, this is my first post in the Neo4j community. So hi y'all!