BootFailureException in Enterprise 4.3.2 installation(solved)

I didn't get this kind of error before 4.3.2 version. So I am at a loss. There is no log file in the logs folder. I am testing it on the same machine I have tested previous versions up to 4.3.1 without problem.

dh@dhhome:~/neo4j-enterprise-4.3.2$ bin/neo4j start --verbose
Directories in use:
home: /home/dh/neo4j-enterprise-4.3.2
config: /home/dh/neo4j-enterprise-4.3.2/conf
logs: /home/dh/neo4j-enterprise-4.3.2/logs
plugins: /home/dh/neo4j-enterprise-4.3.2/plugins
import: /home/dh/neo4j-enterprise-4.3.2/import
data: /home/dh/neo4j-enterprise-4.3.2/data
certificates: /home/dh/neo4j-enterprise-4.3.2/certificates
licenses: /home/dh/neo4j-enterprise-4.3.2/licenses
run: /home/dh/neo4j-enterprise-4.3.2/run
Starting Neo4j.
Unable to start. See user log for details.
org.neo4j.server.startup.BootFailureException: Failure to create the user log file /home/dh/neo4j-enterprise-4.3.2/logs/neo4j.log due to /home/dh/neo4j-enterprise-4.3.2/logs/neo4j.log
at org.neo4j.server.startup.AbstractUnixBootloaderOs.start(
at org.neo4j.server.startup.UnixBootloaderOs.start(
at org.neo4j.server.startup.Bootloader.start(
at org.neo4j.server.startup.Neo4jCommand$
at org.neo4j.server.startup.Neo4jCommand$
at picocli.CommandLine.executeUserObject(
at picocli.CommandLine.access$1300(
at picocli.CommandLine$RunLast.executeUserObjectOfLastSubcommandWithSameParent(
at picocli.CommandLine$RunLast.handle(
at picocli.CommandLine$RunLast.handle(
at picocli.CommandLine$AbstractParseResultHandler.execute(
at picocli.CommandLine.execute(
at org.neo4j.server.startup.Neo4jCommand.main(

I got other error when I tried to run with bin/neo4 console:

2021-08-01 14:04:22.271+0000 INFO Starting...
ERROR StatusLogger Unable to create file /home/dh/neo4j-enterprise-4.3.2/logs/debug.log Permission denied

Now I could solve the problem by running with "sudo bin/neo4j start".
But I couldn't use chrome browser I used before. I tried firefox and it worked to connect to neo4j 4.3.2 server successfully.
I think it's not the best solution but a workaround.
And I got another problem. I couldn't stop the server by "bin/neo4j stop"

It was solved by downloading the file from the link in the mail sent by the download page. The first one was gathered by wget ... directly and it must have some issue not found when I downloaded the previous versions same way.

The owner and group of the log file is important.
sudo chown neo4j:neo4j debug.log maybe

Carefull I don't want to break your file system.

Thank you for your tip. I tried "wget ..." & tar it again today. It worked well again without any action this time. I can't understand what was the difference or the cause of the problem yesterday.

It's a linux user right file system error I think, java who is a part of neo4j needs to be able to read your log file and it wasn't.

I had a similar issue when I fucked up my database because i was playing too much with the sudo command. The files who are used by neo4j needs to be owned by the neo4j user on the server installation not sure about desktop