Backup and restore in Neo4j causal cluster (Azure vm)

i am using azure vm neo4j enterprise edition and have created causal cluster of 3 nodes. I am accessing it through command prompt by the provided credentials(linux server).
i am trying to take backup. and followed all the steps given in

Also,done some certain configuration changes at every neo4j instance in their as shown in attach picture.(not sure it is right or not)

I also tried by editing dbms.mode=SINGLE in neo4j.conf file and performed unwind command referring to the similar post in the community.But it didnot work for me.

i have tried executing backup and restore command on one of the instance from my system.
then i tried executing backup and restore command from individual instance(all 3 core of causal cluster).
In both the case,back and restore were showing successful.
But after entering to cypher-shell and executing command :show databases; it is showing error as shown in the below picture

ramyadb is being backedup and the backupdb is the restored database.(which is being created after the restoration command executed.) The currentstatus is showing dirty and error is an error occurred! Unable to create database backupdb
Please help me.
i have seen a lot of documentation.But not able to resolve this issue.

I am new to neo4j admin. I may be missing any small step for restoring and backup.

It would be a kind help if anyone can help me !


1 Like

I found the solution and sharing as it would help others,


1.	Run the below command in cmd:
     sudo chown neo4j -R /var/lib/neo4j/data/
  1. Start the databases. Backup and Restore will be sucessful
1 Like