AWS Marketplace Community Edition up, but not connecting

Hey all,

I've used this AWS marketplace ami to get my first cloud-based neo4j instance up and running: AWS Marketplace: Neo4j - Community Edition. I selected v4.1 as that's what I've been working with locally.

There's the missing SSL certificate issue, but I've just accepted that in the browser for now, and have got through to the https://.../browserendpoint and can see neo4j's web interface. So, it's definitely up and running.

But, I cannot connect to the actual database, in the :server connect panel. I have used the username neo4j and the instance_id as the password (including checking for dodgy whitespace issues). No luck, on either the neo4j+s nor bolt+s connection options.

I get the following error: Neo.ClientError.Security.Unauthorized: The client is unauthorized due to authentication failure.

I tried from Neo4J Desktop and got Unable to establish remote connection: Database is unreachable with specified configuration.

I also did some googling, and tried to SSH into the ami instance. I have the correct pem key as shown in the ec2 panel. Also no luck.

So, not sure what's going on. Or what I can do to track down the issue. Without being able to ssh in, I certainly cannot do anything with the neo4j config files.

Any ideas?

Many thanks in advance

1 Like