App initialization error in neo4j desktop

I installed neo4j desktop on my windows laptop. It works fine for a few days but the app does not launch after that. I tried reinstalling it a lot of times and the same thing happens - Works fine for a few days and then does not launch.

I see this error message in the neo4j logs everytime this error happens-

App initialization error: SyntaxError: Malformed JSON in file: C:\Users\Indra_K\.Neo4jDesktop\persist\projects.json
Unexpected token < in JSON at position 0 {
  constructor: 'SyntaxError',
  stack: 'SyntaxError: Malformed JSON in file: C:\\Users\\Indra_K\\.Neo4jDesktop\\persist\\projects.json\n' +
    'Unexpected token < in JSON at position 0\n' +
    '    at FileAsync.parse [as deserialize] (<anonymous>)\n' +
    '    at C:\\Program Files\\Neo4j Desktop\\resources\\app.asar\\node_modules\\lowdb\\adapters\\FileAsync.js:41:35\n' +
    '    at async C:\\Program Files\\Neo4j Desktop\\resources\\app.asar\\dist\\\n' +
    '    at async C:\\Program Files\\Neo4j Desktop\\resources\\app.asar\\dist\\'

Hi indranpw.
I have a similar problem and no idea how to solve it. I wonder whether you managed to solve the problem.
Best Markus

You must to find the .json file that the error message talks about it then try to copy the backup file , in my case was the "notifications.json" , looks like you have to find the "projects.json" file


1 Like

This worked for me thanks!