APOC unable to Load : set apoc.import.file.enabled=true in your apoc.conf

I am getting the "Failed to invoke procedure apoc.load.json: Caused by: java.lang.RuntimeException: Import from files not enabled, please set apoc.import.file.enabled=true in your apoc.conf" in my local db. I am on Neo4j 4.1.0, APOC

I have read the documentation and worked with an expert, but the process still fails. Attached are my two conf filesneo4j.zip.txt (12.1 KB)

On advice from a few different posters, I have already taken these steps

  1. Created apoc.conf with the commands recommended by Michael Hunger
  2. updated neo4j.conf with the security recommendations
  3. Deinstalled and reinstalled APOC

After each one, I did a stop/start/reboot. Still the same message. What am I missing ?


what happens if you add


to the bottom of your neo4j.conf ?

It is in there already I believe but we did try that with no luck

i see in the config this value.


I believe it should be


you have the words in reverse order.

Yep. Can't tell you how long I have stared at that without seeing it. Thank you

1 Like