After NEO4J V4.0.0 upgrade - HTTPS set to enabled, but no SSL policy provided - ERROR

Hi All
Just going through an upgrade of Community V3.5 to V4.0
After a couple of false starts - due to a plugin - had success with - Successfully finished upgrade of database

When I now start -
sudo systemctl start neo4j
sudo journalctl -e -u neo4j
I am seeing this error
ERROR Failed to start Neo4j on localhost:7474: HTTPS set to enabled, but no SSL policy provided

Accordng to - - to enable ssl policy for https I need to have the following in my neo4j.conf
As I don't I'm unsure why I am getting this error


Hi pmedlin57, Did you place certificates at certificates/<scope> and its permission.

I have not enabled https in my neo4j.conf

I have reverted back to 3.5.14 until this issue can be explained

I ran into this exact error.
As I am just doing some development with Neo4j -- no production side things yet I haven't been using https/ssl. I didn't realize that the v3.5 neo4j.conf file that I brought over from my v3.5 server to the v4.0 server had dbms.connector.https.enabled=true set. I'm assuming you checked this, but I didn't and commenting it out solved my problem immediately.

So my confusion was that I used the neo4j.conf file that comes with V4 and made just the change to point to my database and didn't make any change to enable https, just as I had not made any change in V3.5
So as per the install instructions I thought I did not have dbms.connector.https.enabled=true, hence my response above and I clearly did a man-check when I looked
But as wdrosko has pointed out - they are both true in V3.5 and in V4
SO this appears to be an undocumented change betwen V3.5 and V4 - that is -
In V3.5 this
#HTTP Connector. There can be zero or one HTTP connectors.

#HTTPS Connector. There can be zero or one HTTPS connectors.

results in the use of http
BUT in V4 it results in the attempt to use HTTPS - and hence this confusion
Thanks wdrosko