After creating a Project and database, how do I get back to 'No project' databases?

Hello. It seems really silly, but after creating a project through the Neo4j desktop application (v1.3.8) I can't seem to get back to my other databases!


When I click the 'Neo4j Tutorial' database I made earlier, it only opens a windows explorer windows in the directory it is stored. How do I get back my access to databases under 'No project' ? I can't seem to find a 'go back' button, and restarting the application puts me back into the project...

Hey @Queuebee, the top icon in the sidebar is the projects section, if you click it you'll be able to switch between projects. Let me know if that helps :)

Hello @nglgzz, thanks for your reply. I can't test it right now but If i remember correct it only took me back to the project itself, as when you select it intitially, with no option to go back to an overview and no sign of the other (non-) projects. I thought maybe, since there's only one project, it automatically takes me to that one...
I'll check again this evening!

I removed the project I had, but I still cant see a way get back to my non-project databases.
(top image shows empty projects section, bottom image shows the current 'No project' and two databases that I can't acces through neo4j desktop, but when I click them, a file explorer opens)

If for example I click on "No project" or "Neo4j Tutorial", it opens file explorer in the directory, but doesn't show anything about the (non)project or database.

I'm slightly confused. Is "No project" a project with that name or you managed to create databases outside of a project? I tried to remove all projects and I cannot do anything outside a project context (which is the intended behavior).

I'll try to explain as best as I can.

Apparently I managed to create it outside of a project, then. What I remember was the 'example' database, the movie database I think. It looked similar to this. I created my 'tutorial' database next to it.

I later removed the movie database as I was not going to use it, but then I got issues with logging in to the database I made myself ( change-password button did not work and I couldn't get back into my database without auth=false) I cloned that 'tutorial' database, still, not in any Project I made myself. But still got issues with logging in...

So then I finally created a project to start over. To test if maybe, within a project, It would work. But it still had reset-password issues. (I asked a question about that here)

Does any of this make sense? So, I'm stuck without any projects, and the databases I see, I can't access by clicking on... Because it opens the file explorer instead of the 'no project' project.

Even though the context-menu here shows copy/paste, clicking the 'No project' (or any of the databses under it) just opens Windows file explorer in the directory...

The first time Desktop is started, an example project is created with the Movie database inside it, so your database should have been inside a project. Not sure how it ended up moving in "No project" though.

What you can do to get the databases to show up again is to assign them a project.

  • Press ctrl+k
  • Type logs and press enter
  • A directory will open up. Open the persist folder inside it.
  • Update the database.json file by setting a projectId for the databases that have no project (you can find the project IDs in the projects.json file).
  • Restart Desktop

Let me know if that helps

1 Like

Yes that worked! Thank you so much! One little remark on the filename, I edited the databases.json file.

1 Like